What Name for This Method?
What Name for This Method?
public class OptionsAwareObject {
private Options options;
public void updateOptions(String fontName, int fontSize) {
options.setFontName(fontName);
options.setFontSize(fontSize);
}
}
class Options {
private int foregroundColor;
private int backgroundColor;
private String fontName;
private int fontSize;
// ...
}
Is updateOptions
a good name for this method? Of course not! updateOptions
is a general name that suggests a comprehensive update of options. Meanwhile, we are only updating font-related information. The responsibility of the method is thus the change of font-related options. A better name would be:
You Shouldn't Run with a Broken Leg!
You Shouldn’t Run with a Broken Leg!
Clear? Obvious? It seems so, yet we continuously run with broken legs…
Read More